summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-20041019-r3.ebuild')
-rw-r--r--app-emulation/wine/wine-20041019-r3.ebuild124
1 files changed, 0 insertions, 124 deletions
diff --git a/app-emulation/wine/wine-20041019-r3.ebuild b/app-emulation/wine/wine-20041019-r3.ebuild
deleted file mode 100644
index 56f4ff1ea083..000000000000
--- a/app-emulation/wine/wine-20041019-r3.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.27 2006/06/24 07:46:36 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="free implementation of Windows(tm) on Unix"
-HOMEPAGE="http://www.winehq.com/"
-SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-*"
-IUSE="X alsa arts cups doc gif glut jack jpeg lcms nas ncurses opengl oss"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-gfx/fontforge
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- X? ( || ( ( x11-libs/libXrandr x11-libs/libXi x11-libs/libXmu
- x11-libs/libXxf86dga x11-libs/libXxf86vm x11-apps/xmessage )
- virtual/x11 )
- )
- arts? ( kde-base/arts )
- alsa? ( media-libs/alsa-lib )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- gif? ( media-libs/giflib )
- jpeg? ( media-libs/jpeg )
- glut? ( virtual/glut )
- lcms? ( media-libs/lcms )"
-DEPEND="${RDEPEND}
- X? ( || ( ( x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- )
- virtual/x11
- )
- )
- sys-devel/bison
- doc? ( app-text/docbook-sgml-utils app-text/jadetex )
- sys-devel/flex"
-
-src_unpack() {
- unpack Wine-${PV}.tar.gz
-
- cd "${S}"
- epatch "${FILESDIR}"/wine-wmf.patch
- epatch "${FILESDIR}"/wine-20041019-alsa-headers.patch
- epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-no-ssp.patch #66002
- epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
- epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
- epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
- sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-}
-
-config_cache() {
- local h ans="no"
- use ${1} && ans="yes"
- shift
- for h in "$@" ; do
- export ac_cv_${h}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- config_cache jack header_jack_jack_h
- config_cache cups header_cups_cups_h
- config_cache alsa header_alsa_asoundlib_h header_sys_asoundlib_h lib_asound_snd_pcm_open
- use arts || export ARTSCCONFIG="/bin/false"
- config_cache nas header_audio_audiolib_h header_audio_soundlib_h
- config_cache gif header_gif_lib_h
- config_cache glut lib_glut_glutMainLoop
- config_cache jpeg header_jpeglib_h
- config_cache oss header_sys_soundcard_h header_machine_soundcard_h header_soundcard_h
- config_cache lcms header_lcms_h
-
- strip-flags
- use lcms && append-flags -I${ROOT}/usr/include/lcms
-
- # $(use_enable amd64 win64)
- # USE=debug is broken in this release
- # $(use_enable debug trace)
- # $(use_enable debug)
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
- if use doc ; then
- VARTEXFONTS=${T} \
- emake -j1 -C documentation doc || die "docs"
- fi
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- bindir=${D}/usr/bin \
- datadir=${D}/usr/share \
- includedir=${D}/usr/include/wine \
- sysconfdir=${D}/etc/wine \
- mandir=${D}/usr/share/man \
- libdir=${D}/usr/lib \
- dlldir=${D}/usr/lib/wine \
- install || die
- use doc && dodoc documentation/*.pdf
-
- insinto /usr/share/wine
- doins documentation/samples/config || die "doins config"
-
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
-}