summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild')
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
index 44bcd1038367..6b627769c94f 100644
--- a/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild,v 1.4 2012/05/03 19:24:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild,v 1.5 2012/09/26 03:23:09 naota Exp $
-EAPI="1"
+EAPI="2"
inherit libtool
@@ -25,17 +25,18 @@ DEPEND="${DEPEND}
nls? ( sys-devel/gettext )
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
elibtoolize
}
-src_compile() {
+src_configure() {
econf \
$(use_enable nls) \
--disable-static \
- --disable-dependency-tracking
+ --disable-dependency-tracking || die
+}
+
+src_compile() {
emake || die "emake failed"
}