summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-hangul/scim-hangul-0.2.2.ebuild')
-rw-r--r--app-i18n/scim-hangul/scim-hangul-0.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-i18n/scim-hangul/scim-hangul-0.2.2.ebuild b/app-i18n/scim-hangul/scim-hangul-0.2.2.ebuild
new file mode 100644
index 000000000000..36fbb56959a1
--- /dev/null
+++ b/app-i18n/scim-hangul/scim-hangul-0.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/scim-hangul-0.2.2.ebuild,v 1.1 2006/06/03 10:51:48 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Hangul IMEngine for SCIM ported from imhangul"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="|| ( >=app-i18n/scim-0.99.8 >=app-i18n/scim-cvs-0.99.8 )"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM with both GTK2 and XIM, you should use the following"
+ einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo
+}