summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-m17n/scim-m17n-0.2.0.ebuild')
-rw-r--r--app-i18n/scim-m17n/scim-m17n-0.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-i18n/scim-m17n/scim-m17n-0.2.0.ebuild b/app-i18n/scim-m17n/scim-m17n-0.2.0.ebuild
new file mode 100644
index 000000000000..1122df796a27
--- /dev/null
+++ b/app-i18n/scim-m17n/scim-m17n-0.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-m17n/scim-m17n-0.2.0.ebuild,v 1.1 2006/02/10 22:54:12 liquidx Exp $
+
+DESCRIPTION="scim-m17n is an input module for Smart Common Input Method (SCIM) which uses m17n as backend"
+HOMEPAGE="http://www.scim-im.org/projects/imengines"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="|| ( >=app-i18n/scim-0.99.8 >=app-i18n/scim-cvs-0.99.8 )
+ >=dev-libs/m17n-lib-1.0.2-r1"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM with both GTK2 and XIM, you should use the following"
+ einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo
+}