summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/acerhk/acerhk-0.5.31.ebuild')
-rw-r--r--app-laptop/acerhk/acerhk-0.5.31.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-laptop/acerhk/acerhk-0.5.31.ebuild b/app-laptop/acerhk/acerhk-0.5.31.ebuild
index e319a7313d8b..4903f0f59d14 100644
--- a/app-laptop/acerhk/acerhk-0.5.31.ebuild
+++ b/app-laptop/acerhk/acerhk-0.5.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.31.ebuild,v 1.2 2006/05/14 23:43:12 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.31.ebuild,v 1.3 2006/11/25 13:21:35 jurek Exp $
inherit linux-mod
@@ -15,6 +15,14 @@ IUSE=""
MODULE_NAMES="acerhk(extra:)"
BUILD_TARGETS="all"
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/kernel-2.6.19-config.h.patch || die "epatch failed"
+}
+
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERNELSRC=${KV_DIR} KERNELVERSION=${KV_FULL}"