summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pax-utils/pax-utils-0.0.8.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-0.0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/pax-utils/pax-utils-0.0.8.ebuild b/app-misc/pax-utils/pax-utils-0.0.8.ebuild
new file mode 100644
index 000000000000..3d09c61860c8
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.0.8.ebuild,v 1.1 2005/05/21 18:57:15 solar Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Various ELF related utils for ELF32, ELF64 binaries useful for displaying PaX and security info on a large groups of bins"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.gz
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~mips ~sparc ~hppa ~amd64 ~ia64 ~ppc64"
+IUSE="caps"
+
+DEPEND="virtual/libc
+ caps? ( sys-libs/libcap )"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ if use caps; then
+ append-flags -DWANT_SYSCAP
+ append-ldflags -lcap
+ fi
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" all || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README
+}