summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/worker/worker-2.14.4.ebuild')
-rw-r--r--app-misc/worker/worker-2.14.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/worker/worker-2.14.4.ebuild b/app-misc/worker/worker-2.14.4.ebuild
new file mode 100644
index 000000000000..15d551e141d4
--- /dev/null
+++ b/app-misc/worker/worker-2.14.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/worker/worker-2.14.4.ebuild,v 1.1 2007/04/29 16:35:53 dertobi123 Exp $
+
+inherit eutils
+
+DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone"
+HOMEPAGE="http://www.boomerangsworld.de/worker/"
+SRC_URI="http://www.boomerangsworld.de/worker/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avfs unicode"
+#S="${WORKDIR}/${P/_}"
+
+DEPEND="|| ( x11-libs/libSM virtual/x11 )
+ avfs? ( sys-fs/avfs )"
+
+src_compile() {
+ econf $(use_enable unicode utf-8) \
+ $(use_with avfs) || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+ doman man/worker.1
+ dodoc AUTHORS ChangeLog INSTALL NEWS README README_LARGEFILES THANKS
+ make_desktop_entry ${PN} Worker WorkerIcon.xpm "FileManager"
+}