summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gtypist/ChangeLog10
-rw-r--r--app-misc/gtypist/files/gtypist-2.8-xemacs-compat.patch18
-rw-r--r--app-misc/gtypist/gtypist-2.8.ebuild62
3 files changed, 88 insertions, 2 deletions
diff --git a/app-misc/gtypist/ChangeLog b/app-misc/gtypist/ChangeLog
index ade85bd9cb9a..7527f76f680b 100644
--- a/app-misc/gtypist/ChangeLog
+++ b/app-misc/gtypist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/gtypist
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.15 2009/06/21 18:55:50 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.16 2010/01/17 23:36:37 cla Exp $
+
+*gtypist-2.8 (17 Jan 2010)
+
+ 17 Jan 2010; Dawid Węgliński <cla@gentoo.org> +gtypist-2.8.ebuild,
+ +files/gtypist-2.8-xemacs-compat.patch:
+ Version bump (bug #300567)
21 Jun 2009; Hans de Graaff <graaff@gentoo.org> gtypist-2.7-r1.ebuild:
Rename virtual/xemacs -> app-editors/xemacs since the virtual has been
diff --git a/app-misc/gtypist/files/gtypist-2.8-xemacs-compat.patch b/app-misc/gtypist/files/gtypist-2.8-xemacs-compat.patch
new file mode 100644
index 000000000000..6b4af23392ea
--- /dev/null
+++ b/app-misc/gtypist/files/gtypist-2.8-xemacs-compat.patch
@@ -0,0 +1,18 @@
+--- gtypist-2.8-orig/tools/gtypist-mode.el 2003-09-28 23:35:22.000000000 +0200
++++ gtypist-2.8/tools/gtypist-mode.el 2007-04-21 14:49:16.000000000 +0200
+@@ -95,7 +95,14 @@
+
+ (require 'font-lock)
+ (require 'thingatpt)
+-(require 'executable) ;; executable-find
++
++(eval-and-compile
++ (cond
++ ((fboundp 'executable-find))
++ ((fboundp 'locate-file)
++ (defun executable-find (command)
++ (locate-file command exec-path nil 'executable)))
++ (t (require 'executable))))
+
+ (defvar gtypist-mode-syntax-table nil "Syntax-table for gtypist-mode.")
+ (unless gtypist-mode-syntax-table
diff --git a/app-misc/gtypist/gtypist-2.8.ebuild b/app-misc/gtypist/gtypist-2.8.ebuild
new file mode 100644
index 000000000000..c4d85b16334a
--- /dev/null
+++ b/app-misc/gtypist/gtypist-2.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.8.ebuild,v 1.1 2010/01/17 23:36:37 cla Exp $
+
+inherit eutils elisp-common
+
+DESCRIPTION="Universal typing tutor"
+HOMEPAGE="http://www.gnu.org/software/gtypist/"
+SRC_URI="mirror://gnu/gtypist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls emacs xemacs"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ emacs? ( virtual/emacs )
+ xemacs? ( !emacs? ( app-editors/xemacs app-xemacs/fsf-compat ) )"
+
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P/8/7}-xemacs-compat.patch
+}
+
+src_compile() {
+ local lispdir=""
+ if use emacs; then
+ lispdir="${SITELISP}/${PN}"
+ einfo "Configuring to build with GNU Emacs support"
+ elif use xemacs; then
+ lispdir="/usr/lib/xemacs/site-packages/lisp/${PN}"
+ einfo "Configuring to build with XEmacs support"
+ fi
+
+ econf $(use_enable nls) \
+ EMACS=$(usev emacs || usev xemacs || echo no) \
+ --with-lispdir="${lispdir}" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}