summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/dia/dia-0.87.ebuild')
-rw-r--r--app-office/dia/dia-0.87.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-office/dia/dia-0.87.ebuild b/app-office/dia/dia-0.87.ebuild
index b9b1ebd17526..6bf682aebd35 100644
--- a/app-office/dia/dia-0.87.ebuild
+++ b/app-office/dia/dia-0.87.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.87.ebuild,v 1.1 2001/05/10 01:55:17 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.87.ebuild,v 1.2 2001/05/10 03:51:37 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,7 +10,9 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
DEPEND=">=gnome-base/gnome-print-0.24
- >=app-arch/rpm-3.0.5"
+ >=app-arch/rpm-3.0.5
+ bonobo? ( gnome-base/bonobo )
+ python? ( dev-lang/python-2.0 )"
src_compile() {
@@ -20,17 +22,20 @@ src_compile() {
then
myconf="--enable-bonobo"
fi
+# if [ "`use python`" ]
+# then
+# myconf="$myconf --with-python"
+# fi
try ./configure --host=${CHOST} --prefix=/opt/gnome \
--sysconfdir=/etc/opt/gnome \
--enable-gnome --enable-gnome-print ${myconf}
- # bonobo support does not work yet
try make
}
src_install () {
- try make prefix=${D}/opt/gnome sysconfdir=${D}7etc/opt/gnome install
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
}