summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/kpresenter/kpresenter-1.4.0_rc1.ebuild')
-rw-r--r--app-office/kpresenter/kpresenter-1.4.0_rc1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-office/kpresenter/kpresenter-1.4.0_rc1.ebuild b/app-office/kpresenter/kpresenter-1.4.0_rc1.ebuild
new file mode 100644
index 000000000000..bb6d5eba89ca
--- /dev/null
+++ b/app-office/kpresenter/kpresenter-1.4.0_rc1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kpresenter/kpresenter-1.4.0_rc1.ebuild,v 1.1 2005/06/03 15:17:55 greg_g Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=${PV}
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice presentation program."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoscript lib/koscript
+ libkospell lib/kospell
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kpresenter"
+
+need-kde 3.3
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter kpresenter" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}