summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/lyx/lyx-1.2.1.ebuild')
-rw-r--r--app-office/lyx/lyx-1.2.1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/app-office/lyx/lyx-1.2.1.ebuild b/app-office/lyx/lyx-1.2.1.ebuild
index 2725c1f82de7..634cc67156bc 100644
--- a/app-office/lyx/lyx-1.2.1.ebuild
+++ b/app-office/lyx/lyx-1.2.1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.1.ebuild,v 1.7 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.1.ebuild,v 1.8 2002/11/30 23:37:22 vapier Exp $
-IUSE="nls cups"
-
-S=${WORKDIR}/${P}
DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
HOMEPAGE="http://www.lyx.org/"
@@ -12,6 +9,7 @@ HOMEPAGE="http://www.lyx.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
+IUSE="nls cups"
# This lyx-base ebuild only depends on the absolutely necessary packages.
# The acompanying lyx-utils ebuild depends on lyx-base and on everything
@@ -38,7 +36,6 @@ RDEPEND="${DEPEND}
app-text/chktex"
src_compile() {
-
use nls || myconf="${myconf} --disable-nls"
[ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
@@ -50,18 +47,17 @@ src_compile() {
#./autogen.sh
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
#--infodir='$(prefix)/share/info' \
#--with-extra-inc=/usr/X11R6/include \
#--mandir='$(prefix)/share/man' \
emake || die "emake failed"
}
-src_install () {
+src_install() {
# The 'install-strip' target is provided by the LyX makefile
# for stripping installed binaries. Use prefix= instead of
# DESTDIR=, otherwise it violates the sandbox in the po directory.
- einstall || die
+ einstall
dodoc README* UPGRADING INSTALL* ChangeLog NEW COPYING ANNOUNCE ABOUT-NLS
}
-