summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/openerp-client/openerp-client-5.0.15-r1.ebuild')
-rw-r--r--app-office/openerp-client/openerp-client-5.0.15-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-office/openerp-client/openerp-client-5.0.15-r1.ebuild b/app-office/openerp-client/openerp-client-5.0.15-r1.ebuild
new file mode 100644
index 000000000000..d57ac87d13fc
--- /dev/null
+++ b/app-office/openerp-client/openerp-client-5.0.15-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/openerp-client/openerp-client-5.0.15-r1.ebuild,v 1.1 2011/01/08 06:45:29 elvanor Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+inherit eutils distutils python
+
+DESCRIPTION="Open Source ERP & CRM"
+HOMEPAGE="http://www.openerp.com/"
+SRC_URI="http://www.openerp.com/download/stable/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/matplotlib
+ dev-python/egenix-mx-base
+ x11-libs/hippo-canvas[python]"
+
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ distutils_src_install
+ rm "${D}/usr/bin/openerp-client"
+ dobin "${FILESDIR}/openerp-client"
+ insinto "/usr/share/applications"
+ doins "${FILESDIR}/openerp-client.desktop"
+}