summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild')
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
index 9645dacd85aa..ebd09e7938e5 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild,v 1.20 2004/11/11 23:34:06 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild,v 1.21 2004/11/15 14:53:54 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -26,7 +26,7 @@
# Get support going for installing a custom language pack. Also
# need to be able to install more than one language pack.
-inherit flag-o-matic eutils gcc
+inherit flag-o-matic eutils toolchain-funcs
IUSE="gnome kde"
@@ -174,11 +174,6 @@ oo_setup() {
unset LANG
unset LC_ALL
- # We want gcc3 if possible!!!!
- export WANT_GCC_3="yes"
-
- export NEW_GCC="0"
-
if [ -x /usr/sbin/gcc-config ]
then
# Do we have a gcc that use the new layout and gcc-config ?
@@ -340,8 +335,8 @@ src_compile() {
if [ -z "$(grep 'CCCOMP' ${S}/${LinuxEnvSet})" ]
then
# Set CCCOMP and CXXCOMP. This is still needed for STLport
- export CCCOMP="$(gcc-getCC)"
- export CXXCOMP="$(gcc-getCXX)"
+ export CCCOMP="$(tc-getCC)"
+ export CXXCOMP="$(tc-getCXX)"
fi
einfo "Bootstrapping OpenOffice.org..."