summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/texmacs/texmacs-1.0.7.2.ebuild')
-rw-r--r--app-office/texmacs/texmacs-1.0.7.2.ebuild15
1 files changed, 3 insertions, 12 deletions
diff --git a/app-office/texmacs/texmacs-1.0.7.2.ebuild b/app-office/texmacs/texmacs-1.0.7.2.ebuild
index e97f63e4105b..0eaee1a22489 100644
--- a/app-office/texmacs/texmacs-1.0.7.2.ebuild
+++ b/app-office/texmacs/texmacs-1.0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.2.ebuild,v 1.1 2009/04/19 13:19:20 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.2.ebuild,v 1.2 2009/09/07 11:19:08 grozin Exp $
EAPI=2
inherit autotools
MY_P=${P/tex/TeX}-src
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
HOMEPAGE="http://www.texmacs.org/"
LICENSE="GPL-3"
SLOT="0"
-IUSE="imlib jpeg netpbm -qt4 svg spell"
+IUSE="imlib jpeg netpbm svg spell"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
RDEPEND="dev-scheme/guile[deprecated]
@@ -21,7 +21,6 @@ RDEPEND="dev-scheme/guile[deprecated]
media-libs/freetype
x11-libs/libXext
x11-apps/xmodmap
- qt4? ( x11-libs/qt-gui:4 )
imlib? ( media-libs/imlib2 )
jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
@@ -33,13 +32,6 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use qt4; then
- ewarn "Qt port is highly experimental"
- ewarn "If you want a stable TeXmacs, emerge with USE=-qt4"
- fi
-}
-
src_prepare() {
# don't strip
epatch "${FILESDIR}"/${P}-strip.patch
@@ -49,8 +41,7 @@ src_prepare() {
src_configure() {
econf $(use_with imlib imlib2) \
- --enable-optimize="${CXXFLAGS}" \
- $(use_enable qt4 qt)
+ --enable-optimize="${CXXFLAGS}"
}
src_install() {