summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild')
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild b/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
index 1c1ef12a014a..cad7dd99a9f9 100644
--- a/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild,v 1.2 2009/05/19 00:28:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild,v 1.3 2009/05/19 00:43:47 robbat2 Exp $
EAPI=2
@@ -23,7 +23,7 @@ BOTH_DEPEND="virtual/libiconv
python? ( >=dev-lang/python-2.4.4-r4 )
png? ( >=media-libs/libpng-1.2.18-r1 )
readline? ( >=sys-libs/readline-5.2_p4 )
- usb? ( >=dev-libs/libusb-0.1.12 )
+ usb? ( virtual/libusb:0 )
bluetooth? ( || ( >=net-wireless/bluez-libs-3.10 net-wireless/bluez ) )"
DEPEND="${BOTH_DEPEND}
@@ -57,6 +57,9 @@ src_prepare() {
# Respect JAVACFLAGS bug #267445
epatch "${FILESDIR}/${P}-respect-javacflags.patch"
+
+ # libusb-compat requires you to check the return value of usb_open!
+ epatch "${FILESDIR}/${P}-libusb-compat-usb_open.patch"
AT_M4DIR="m4" eautoreconf
}