summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-2.05b-r5.ebuild')
-rw-r--r--app-shells/bash/bash-2.05b-r5.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/app-shells/bash/bash-2.05b-r5.ebuild b/app-shells/bash/bash-2.05b-r5.ebuild
deleted file mode 100644
index 74f481574197..000000000000
--- a/app-shells/bash/bash-2.05b-r5.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r5.ebuild,v 1.13 2004/06/29 03:51:06 vapier Exp $
-
-inherit eutils flag-o-matic
-
-# Official patches
-PLEVEL="x002 x003 x004"
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
-SRC_URI="mirror://gnu/bash/${P}.tar.gz
- mirror://gentoo/${P}-gentoo.diff.bz2
- ${PLEVEL//x/mirror://gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips ~alpha hppa amd64"
-IUSE="nls build"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-src_unpack() {
- unpack ${P}.tar.gz
-
- cd ${S}
- epatch ${DISTDIR}/${P}-gentoo.diff.bz2
-
- for x in ${PLEVEL//x}
- do
- epatch ${DISTDIR}/${PN}${PV/\.}-${x}
- done
-
- # Remove autoconf dependency
- cp Makefile.in Makefile.in.orig
- sed -e "/&& autoconf/d" Makefile.in.orig > Makefile.in
-
- # Readline is slow with multibyte locale, bug #19762
- epatch ${FILESDIR}/${P}-multibyte-locale.patch
- # Segfault on empty herestring
- epatch ${FILESDIR}/${P}-empty-herestring.patch
-}
-
-src_compile() {
-
- filter-flags -malign-double
-
- local myconf=""
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #
- # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
- #use readline && myconf="--with-installed-readline"
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- econf \
- --disable-profiling \
- --with-curses \
- --without-gnu-malloc \
- ${myconf} || die
-
- make || die
-}
-
-src_install() {
- einstall || die
-
- dodir /bin
- mv ${D}/usr/bin/bash ${D}/bin
- dosym bash /bin/sh
-
- use build \
- && rm -rf ${D}/usr \
- || ( \
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K
- dodoc doc/FAQ doc/INTRO
-
- ebegin "creating info symlink"
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- eend $?
- )
-}