summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/fish/fish-2.1.0-r1.ebuild')
-rw-r--r--app-shells/fish/fish-2.1.0-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-shells/fish/fish-2.1.0-r1.ebuild b/app-shells/fish/fish-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..18fd2a684374
--- /dev/null
+++ b/app-shells/fish/fish-2.1.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-2.1.0-r1.ebuild,v 1.1 2013/11/04 09:51:08 polynomial-c Exp $
+
+EAPI=5
+
+inherit base autotools
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz
+ https://github.com/fish-shell/fish-shell/commit/9a3643501607bff8b314977931916081dd39646a.patch -> ${P}-docdir.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bc
+ sys-devel/gettext
+ www-client/htmlview
+ X? ( x11-misc/xsel )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}-docdir.patch #489934
+
+ eautoreconf
+}
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --bindir="${EPREFIX}"/bin
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "To use fish as your login shell:"
+ elog "* add the line '${EPREFIX}/bin/${PN}'"
+ elog "* to the file '${EPREFIX}/etc/shells'."
+ elog "* use the command 'chsh -s ${EPREFIX}/bin/${PN}'."
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Have fun!"
+}