summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/diction/diction-1.11.ebuild')
-rw-r--r--app-text/diction/diction-1.11.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/app-text/diction/diction-1.11.ebuild b/app-text/diction/diction-1.11.ebuild
index 4bd8cb2d0d7a..58894b004bdb 100644
--- a/app-text/diction/diction-1.11.ebuild
+++ b/app-text/diction/diction-1.11.ebuild
@@ -1,34 +1,31 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/diction/diction-1.11.ebuild,v 1.2 2007/10/13 22:46:50 mr_bones_ Exp $
-
-inherit eutils versionator
-
-MY_PV=$(replace_version_separator 2 -)
+# $Header: /var/cvsroot/gentoo-x86/app-text/diction/diction-1.11.ebuild,v 1.3 2008/01/16 10:26:18 drac Exp $
DESCRIPTION="Diction and style checkers for english and german texts"
HOMEPAGE="http://www.gnu.org/software/diction/diction.html"
-SRC_URI="http://www.moria.de/~michael/diction/${PN}-${MY_PV}.tar.gz"
+SRC_URI="http://www.moria.de/~michael/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
IUSE="unicode"
-DEPEND="sys-devel/gettext"
-RDEPEND="virtual/libintl"
-
-S="${WORKDIR}"/${PN}-$(get_version_component_range 1-2)
+DEPEND="sys-devel/gettext
+ virtual/libintl"
src_unpack() {
- unpack "${A}"; cd "${S}"
+ unpack ${A}
+ cd "${S}"
if use unicode; then
- iconv -f ISO-8859-1 -t UTF-8 de > de.new || die "charset conversion failed."
- mv de.new de
+ for lang in de nl; do
+ iconv -f ISO-8859-1 -t UTF-8 ${lang} > ${lang}.new || die "iconv failed."
+ mv ${lang}.new ${lang}
+ done
fi
}
src_install() {
- make DESTDIR="${D}" install
+ emake DESTDIR="${D}" install || die "emake install failed."
dodoc NEWS README
}