summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/qpdfview/qpdfview-0.4.11.1.ebuild')
-rw-r--r--app-text/qpdfview/qpdfview-0.4.11.1.ebuild48
1 files changed, 28 insertions, 20 deletions
diff --git a/app-text/qpdfview/qpdfview-0.4.11.1.ebuild b/app-text/qpdfview/qpdfview-0.4.11.1.ebuild
index a3f89989cda4..271ac8c65b54 100644
--- a/app-text/qpdfview/qpdfview-0.4.11.1.ebuild
+++ b/app-text/qpdfview/qpdfview-0.4.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/qpdfview/qpdfview-0.4.11.1.ebuild,v 1.1 2014/09/24 09:48:17 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/qpdfview/qpdfview-0.4.11.1.ebuild,v 1.2 2014/09/28 11:49:13 pesa Exp $
EAPI=5
@@ -16,28 +16,37 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
IUSE="cups dbus djvu fitz +pdf postscript +qt4 qt5 sqlite +svg synctex"
-REQUIRED_USE="^^ ( qt4 qt5 )
- ?? ( fitz pdf )"
+REQUIRED_USE="
+ ^^ ( qt4 qt5 )
+ ?? ( fitz pdf )
+"
-RDEPEND="cups? ( net-print/cups )
+RDEPEND="
+ cups? ( net-print/cups )
djvu? ( app-text/djvu )
fitz? ( app-text/mupdf:0/1.4 )
postscript? ( app-text/libspectre )
- qt4? ( dev-qt/qtcore:4[iconv]
+ qt4? (
+ dev-qt/qtcore:4[iconv]
dev-qt/qtgui:4
dbus? ( dev-qt/qtdbus:4 )
pdf? ( app-text/poppler[qt4] )
sqlite? ( dev-qt/qtsql:4[sqlite] )
- svg? ( dev-qt/qtsvg:4 ) )
- qt5? ( dev-qt/qtcore:5
+ svg? ( dev-qt/qtsvg:4 )
+ )
+ qt5? (
+ dev-qt/qtcore:5
dev-qt/qtgui:5
dbus? ( dev-qt/qtdbus:5 )
pdf? ( >=app-text/poppler-0.26.4[qt5] )
sqlite? ( dev-qt/qtsql:5[sqlite] )
- svg? ( dev-qt/qtsvg:5 ) )
- !svg? ( virtual/freedesktop-icon-theme )"
+ svg? ( dev-qt/qtsvg:5 )
+ )
+ !svg? ( virtual/freedesktop-icon-theme )
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
DOCS=( CHANGES CONTRIBUTORS README TODO )
@@ -47,38 +56,37 @@ src_prepare() {
}
rm_help() {
- if [[ -e "miscellaneous/help_${1}.html" ]]; then
- rm "miscellaneous/help_${1}.html" || die "removing extraneous help files failed"
- fi
+ rm -f "miscellaneous/help_${1}.html" || die "removing extraneous help files failed"
}
- l10n_find_plocales_changes "translations" "${PN}_" '.ts'
+ l10n_find_plocales_changes translations "${PN}_" '.ts'
l10n_for_each_locale_do prepare_locale
l10n_for_each_disabled_locale_do rm_help
+
# adapt for prefix
sed -i -e "s:/usr:${EPREFIX}/usr:g" qpdfview.pri || die
}
src_configure() {
local config i
- for i in cups dbus pdf djvu svg synctex ; do
- if ! use ${i} ; then
+ for i in cups dbus pdf djvu svg synctex; do
+ if ! use ${i}; then
config+=" without_${i}"
fi
done
- use fitz && config+=" with_fitz"
+ use fitz && config+=" with_fitz"
use postscript || config+=" without_ps"
use sqlite || config+=" without_sql"
- if use qt4 ; then
+ if use qt4; then
eqmake4 CONFIG+="${config}" PLUGIN_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/${PN}"
- else
+ else
eqmake5 CONFIG+="${config}" PLUGIN_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/${PN}" qpdfview.pro
fi
}
src_install() {
- emake INSTALL_ROOT="${D}" "$@" install
+ emake INSTALL_ROOT="${D}" install
einstalldocs
}