summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cairomm/cairomm-1.5.0.ebuild')
-rw-r--r--dev-cpp/cairomm/cairomm-1.5.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/cairomm/cairomm-1.5.0.ebuild b/dev-cpp/cairomm/cairomm-1.5.0.ebuild
new file mode 100644
index 000000000000..d88bed669987
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.5.0.ebuild,v 1.1 2008/03/24 22:08:02 remi Exp $
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=x11-libs/cairo-1.5.14"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # backport from git HEAD to fix build issue with cairo 1.5.14
+ epatch "${FILESDIR}/${PN}-1.5.0-fix-new-cairo-API.patch" || die "patch failed"
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable doc docs) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use examples; then
+ dodoc examples
+ fi
+}