summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/ChangeLog10
-rw-r--r--dev-db/unixODBC/files/digest-unixODBC-2.2.126
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.12.ebuild104
3 files changed, 119 insertions, 1 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index 3353a2b7670e..f7a6826f0608 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/unixODBC
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.62 2007/01/04 14:36:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.63 2007/04/01 03:15:15 robbat2 Exp $
+
+*unixODBC-2.2.12 (01 Apr 2007)
+
+ 01 Apr 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +unixODBC-2.2.12.ebuild:
+ Version bump of unixODBC - Bug #111910, thanks to Attila Fazekas
+ <turul16@freemail.hu> for all of the patches. Also fixes bug #143149 for
+ static libraries and bug #169566 for libtool handling.
04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
unixODBC-2.2.11-r1.ebuild:
diff --git a/dev-db/unixODBC/files/digest-unixODBC-2.2.12 b/dev-db/unixODBC/files/digest-unixODBC-2.2.12
new file mode 100644
index 000000000000..76e427f17f80
--- /dev/null
+++ b/dev-db/unixODBC/files/digest-unixODBC-2.2.12
@@ -0,0 +1,6 @@
+MD5 2c34c7d903f0d850da0580e0ae50cad9 unixODBC-2.2.12-r0-patches.tar.bz2 6968
+RMD160 5d53a41f4645cd366e18405d23acbf3f87dc9eda unixODBC-2.2.12-r0-patches.tar.bz2 6968
+SHA256 da58a4c4a08ccef6416af4cac17bd0d6e89f1c513aecab21d9092bcbae0faefd unixODBC-2.2.12-r0-patches.tar.bz2 6968
+MD5 9a116aad4059c31d231b626ffdf1869a unixODBC-2.2.12.tar.gz 2798077
+RMD160 13c9ec87c3fff4a1fceb45ff7a552a0fa8666b16 unixODBC-2.2.12.tar.gz 2798077
+SHA256 d8b425e9cd8bf55ac21653d27e017045013a155a6149ca2930e257a146f9fe40 unixODBC-2.2.12.tar.gz 2798077
diff --git a/dev-db/unixODBC/unixODBC-2.2.12.ebuild b/dev-db/unixODBC/unixODBC-2.2.12.ebuild
new file mode 100644
index 000000000000..a9400b4cf2bf
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.2.12.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.12.ebuild,v 1.1 2007/04/01 03:15:15 robbat2 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+PATCH_VERSION="2.2.12-r0"
+PATCH_P="${PN}-${PATCH_VERSION}-patches"
+
+inherit eutils multilib autotools gnuconfig
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="ODBC Interface for Linux."
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz
+ mirror://gentoo/${PATCH_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="qt3 gnome"
+
+DEPEND=">=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ qt3? ( =x11-libs/qt-3* )
+ gnome? ( gnome-base/libgnomeui )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${WORKDIR}/${PATCH_P}/*
+ #epatch "${FILESDIR}/${P}-configure.in.patch"
+ #epatch "${FILESDIR}/${P}-qt.m4.patch"
+ #epatch "${FILESDIR}/${P}-gODBCConfig-Makefile.am.patch"
+ #epatch "${FILESDIR}/${P}-gODBCConfig-configure.in.patch"
+ #epatch "${FILESDIR}/${P}-gODBCConfig-odbcconfig.c.patch"
+ #epatch "${FILESDIR}/${P}-gODBCConfig-support.c.patch"
+ #epatch "${FILESDIR}/${P}-gODBCConfig-support.h.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use qt3 && ! use mips ; then
+ myconf="--enable-gui=yes --x-libraries=/usr/$(get_libdir)"
+ else
+ myconf="--enable-gui=no"
+ fi
+
+# Detect mips systems properly
+ gnuconfig_update
+ eautoreconf
+
+ econf --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/${PN} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-static \
+ --enable-fdb \
+ ${myconf} || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ if use gnome; then
+ # Symlink for configure
+ ln -s ${S}/odbcinst/.libs ./lib
+ # Symlink for libtool
+ ln -s ${S}/odbcinst/.libs ./lib/.libs
+
+ cd gODBCConfig
+ touch ChangeLog
+ gnuconfig_update
+ autoreconf --install
+ econf --host=${CHOST} \
+ --with-odbc=${S} \
+ --enable-static \
+ --prefix=/usr \
+ --sysconfdir=/etc/${PN} || die "econf gODBCConfig failed"
+ ln -s ../depcomp .
+ ln -s ../libtool .
+
+ emake || die "emake gODBCConfig failed"
+ cd ..
+ fi
+}
+
+
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ if use gnome;
+ then
+ cd gODBCConfig
+ emake DESTDIR=${D} install || die "emake gODBCConfig install failed"
+ cd ..
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README*
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
+ prepalldocs
+}
+