summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/pnetlib/pnetlib-0.7.0.ebuild')
-rw-r--r--dev-dotnet/pnetlib/pnetlib-0.7.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-dotnet/pnetlib/pnetlib-0.7.0.ebuild b/dev-dotnet/pnetlib/pnetlib-0.7.0.ebuild
new file mode 100644
index 000000000000..31c4d76cd49b
--- /dev/null
+++ b/dev-dotnet/pnetlib/pnetlib-0.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnetlib/pnetlib-0.7.0.ebuild,v 1.1 2005/06/21 23:37:02 urilith Exp $
+
+inherit eutils
+
+DESCRIPTION="Portable.NET C# library"
+HOMEPAGE="http://www.dotgnu.org/"
+#SRC_URI="mirror://gnu/dotgnu/pnet/${P}.tar.gz"
+SRC_URI="http://www.southern-storm.com.au/download/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+IUSE="truetype X"
+
+DEPEND="=dev-dotnet/pnet-${PV}*
+ X? ( virtual/x11 )
+ truetype? ( virtual/xft )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # patch configure.in to detect renamed resgen.pnet
+ # bug 39369
+ epatch ${FILESDIR}/${PV}-resgen.patch
+}
+
+src_compile() {
+ local lib_profile="default1.1"
+ einfo "Using profile: ${lib_profile}"
+
+ libtoolize --force --copy || die
+ aclocal || die
+ WANT_AUTOCONF=2.5 ./auto_gen.sh
+ econf --with-profile=${lib_profile} \
+ `use_enable truetype xft` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog HACKING INSTALL NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*.html
+}