summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hashtables')
-rw-r--r--dev-haskell/hashtables/ChangeLog7
-rw-r--r--dev-haskell/hashtables/hashtables-1.0.1.8.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-haskell/hashtables/ChangeLog b/dev-haskell/hashtables/ChangeLog
index 85c54c6cad71..b41d5c89e983 100644
--- a/dev-haskell/hashtables/ChangeLog
+++ b/dev-haskell/hashtables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hashtables
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashtables/ChangeLog,v 1.4 2012/09/12 15:29:44 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashtables/ChangeLog,v 1.5 2012/11/18 06:28:32 gienah Exp $
+
+*hashtables-1.0.1.8 (18 Nov 2012)
+
+ 18 Nov 2012; Mark Wright <gienah@gentoo.org> +hashtables-1.0.1.8.ebuild:
+ Bump hashtables to 1.0.1.8
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org>
hashtables-1.0.1.2.ebuild, hashtables-1.0.1.3.ebuild,
diff --git a/dev-haskell/hashtables/hashtables-1.0.1.8.ebuild b/dev-haskell/hashtables/hashtables-1.0.1.8.ebuild
new file mode 100644
index 000000000000..9a67ba430cf2
--- /dev/null
+++ b/dev-haskell/hashtables/hashtables-1.0.1.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashtables/hashtables-1.0.1.8.ebuild,v 1.1 2012/11/18 06:28:32 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Mutable hash tables in the ST monad"
+HOMEPAGE="http://github.com/gregorycollins/hashtables"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1:=[profile?]
+ <dev-haskell/hashable-2:=[profile?]
+ >=dev-haskell/primitive-0.4:=[profile?]
+ <dev-haskell/primitive-0.6:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ <dev-haskell/vector-0.11:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"