summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/infobus/infobus-1.2.ebuild')
-rw-r--r--dev-java/infobus/infobus-1.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-java/infobus/infobus-1.2.ebuild b/dev-java/infobus/infobus-1.2.ebuild
new file mode 100644
index 000000000000..5a478f0ad20c
--- /dev/null
+++ b/dev-java/infobus/infobus-1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/infobus/infobus-1.2.ebuild,v 1.1 2003/05/15 05:17:28 absinthe Exp $
+
+inherit java-pkg
+
+At="ib12.zip"
+S=${WORKDIR}
+DESCRIPTION="InfoBus enables dynamic exchange of data between JavaBeans component architecture."
+SRC_URI=""
+HOMEPAGE="http://java.sun.com/products/javabeans/infobus/index.html"
+KEYWORDS="x86 ppc sparc alpha mips hppa arm"
+LICENSE="sun-bcla"
+SLOT="0"
+DEPEND=""
+RDEPEND=">=virtual/jdk-1.2"
+IUSE="doc"
+
+src_unpack() {
+ if [ ! -f "${DISTDIR}/${At}" ] ; then
+ echo " "
+ echo "!!! Missing ${DISTDIR}/${At}"
+ echo " "
+ einfo " "
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo " "
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Download ${At}"
+ einfo " 3. Move file to ${DISTDIR}"
+ einfo " 4. Run emerge on this package again to complete"
+ einfo " "
+ die "User must manually download distfile"
+ fi
+ unzip -qq ${DISTDIR}/${At}
+}
+
+src_compile() {
+ einfo " This is a binary-only ebuild."
+}
+
+src_install() {
+ use doc && dohtml -r doc/
+ dohtml *.html
+ java-pkg_dojar infobus.jar
+}
+