summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/ghc-7.8.3.ebuild')
-rw-r--r--dev-lang/ghc/ghc-7.8.3.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-lang/ghc/ghc-7.8.3.ebuild b/dev-lang/ghc/ghc-7.8.3.ebuild
index adbfdab1b83d..f2a21154c00c 100644
--- a/dev-lang/ghc/ghc-7.8.3.ebuild
+++ b/dev-lang/ghc/ghc-7.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.4 2014/07/30 13:20:16 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.5 2014/08/01 09:12:49 slyfox Exp $
EAPI=5
@@ -489,10 +489,10 @@ src_configure() {
src_compile() {
if ! use binary; then
- # 1. build compiler binary(+wrapper) first
- emake inplace/bin/ghc-stage2
+ # 1. build compiler binary first
+ emake ghc/stage2/build/tmp/ghc-stage2
# 2. pax-mark (bug #516430)
- pax-mark -m inplace/lib/bin/ghc-stage2
+ pax-mark -m ghc/stage2/build/tmp/ghc-stage2
# 3. and then all the rest
emake all
fi # ! use binary
@@ -525,11 +525,6 @@ src_install() {
# remove link, but leave 'haddock-${GHC_P}'
rm -f "${ED}"/usr/bin/haddock
- # ghci uses mmap with rwx protection at it implements dynamic
- # linking on it's own (bug #299709)
- # so mark resulting binary
- pax-mark -m "${ED}/usr/$(get_libdir)/${GHC_P}/bin/ghc"
-
if [[ ! -f "${S}/VERSION" ]]; then
echo "${GHC_PV}" > "${S}/VERSION" \
|| die "Could not create file ${S}/VERSION"