summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nasm/nasm-2.08.02.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.08.02.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-lang/nasm/nasm-2.08.02.ebuild b/dev-lang/nasm/nasm-2.08.02.ebuild
deleted file mode 100644
index ae2986f2018d..000000000000
--- a/dev-lang/nasm/nasm-2.08.02.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.08.02.ebuild,v 1.3 2010/08/21 19:42:05 hwoarang Exp $
-
-EAPI=2
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="groovy little assembler"
-HOMEPAGE="http://nasm.sourceforge.net/"
-SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-DEPEND="dev-lang/perl
- doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
-RDEPEND=""
-
-S=${WORKDIR}/${P/_}
-
-src_configure() {
- strip-flags
- econf
-}
-
-src_compile() {
- emake nasmlib.o || die
- emake all || die
- if use doc ; then
- emake doc || die
- fi
-}
-
-src_install() {
- emake INSTALLROOT="${D}" install install_rdf || die
- dodoc AUTHORS CHANGES ChangeLog README TODO
- if use doc ; then
- doinfo doc/info/*
- dohtml doc/html/*
- dodoc doc/nasmdoc.*
- fi
-}