summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/pugs')
-rw-r--r--dev-lang/pugs/ChangeLog8
-rw-r--r--dev-lang/pugs/files/digest-pugs-6.2.133
-rw-r--r--dev-lang/pugs/files/pugs-6.2.13-build_dir.patch11
-rw-r--r--dev-lang/pugs/pugs-6.2.13.ebuild34
4 files changed, 55 insertions, 1 deletions
diff --git a/dev-lang/pugs/ChangeLog b/dev-lang/pugs/ChangeLog
index e04c1eb5fc78..c68270031d76 100644
--- a/dev-lang/pugs/ChangeLog
+++ b/dev-lang/pugs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/pugs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pugs/ChangeLog,v 1.11 2006/09/13 17:59:52 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pugs/ChangeLog,v 1.12 2006/10/18 19:44:20 yuval Exp $
+
+*pugs-6.2.13 (18 Oct 2006)
+
+ 18 Oct 2006; Yuval Yaari <yuval@gentoo.org>
+ +files/pugs-6.2.13-build_dir.patch, +pugs-6.2.13.ebuild:
+ Version bump
*pugs-6.2.12 (13 Aug 2006)
diff --git a/dev-lang/pugs/files/digest-pugs-6.2.13 b/dev-lang/pugs/files/digest-pugs-6.2.13
new file mode 100644
index 000000000000..b0c0389935ca
--- /dev/null
+++ b/dev-lang/pugs/files/digest-pugs-6.2.13
@@ -0,0 +1,3 @@
+MD5 07689a124f3550476083a29176d69744 Perl6-Pugs-6.2.13.tar.gz 6839270
+RMD160 31f0bd53abaa244f815f70546ffe16180273b70f Perl6-Pugs-6.2.13.tar.gz 6839270
+SHA256 300f056c960d450f6e6d77358da7a7ce05bf0ff6fb7a0725cbddaaee017afc27 Perl6-Pugs-6.2.13.tar.gz 6839270
diff --git a/dev-lang/pugs/files/pugs-6.2.13-build_dir.patch b/dev-lang/pugs/files/pugs-6.2.13-build_dir.patch
new file mode 100644
index 000000000000..8e0d5a19b01d
--- /dev/null
+++ b/dev-lang/pugs/files/pugs-6.2.13-build_dir.patch
@@ -0,0 +1,11 @@
+--- Makefile.PL.old 2006-10-18 23:23:43.000000000 +0000
++++ Makefile.PL 2006-10-18 23:24:16.000000000 +0000
+@@ -449,7 +449,7 @@
+ my $icuflags = parrot_config($base, $parrot_config, 'icu_shared');
+ my $include_path = parrot_config($base, $parrot_config, 'prefix') . parrot_config($base, $parrot_config, 'inc');
+ my $rpath_blib = parrot_config($base, $parrot_config, 'rpath_blib');
+- my $build_dir = parrot_config($base, $parrot_config, 'top_builddir', 'build_dir');
++ my $build_dir = $ENV{PARROT_PATH};
+ my $is_shared = parrot_config($base, $parrot_config, 'parrot_is_shared');
+ my $parrot_libdir = parrot_config($base, $parrot_config, 'lib_dir');
+
diff --git a/dev-lang/pugs/pugs-6.2.13.ebuild b/dev-lang/pugs/pugs-6.2.13.ebuild
new file mode 100644
index 000000000000..1f0f31eefca3
--- /dev/null
+++ b/dev-lang/pugs/pugs-6.2.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pugs/pugs-6.2.13.ebuild,v 1.1 2006/10/18 19:44:21 yuval Exp $
+
+inherit perl-module multilib eutils
+
+MY_P="Perl6-Pugs-${PV}"
+S="${WORKDIR}/-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Pugs is an implementation of Perl 6, written in Haskell"
+HOMEPAGE="http://pugscode.org/"
+SRC_URI="mirror://cpan/authors/id/A/AU/AUDREYT/${MY_P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+IUSE=""
+
+DEPEND="dev-perl/Term-ReadLine-Perl
+ || ( >=dev-lang/ghc-bin-6.4.2 >=dev-lang/ghc-6.4.2 )
+ >=dev-lang/parrot-0.4.6"
+
+export PARROT_PATH="/usr/$(get_libdir)/parrot"
+#this links against parrot and perl5 - if threads was used to compile perl5 this is not supported here
+export PUGS_EMBED="parrot perl5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-build_dir.patch
+}