summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.3.0-r1.ebuild')
-rw-r--r--dev-lang/python/python-3.3.0-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/python/python-3.3.0-r1.ebuild b/dev-lang/python/python-3.3.0-r1.ebuild
index ea6a161b0efb..060dd8197a31 100644
--- a/dev-lang/python/python-3.3.0-r1.ebuild
+++ b/dev-lang/python/python-3.3.0-r1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0-r1.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0-r1.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
WANT_LIBTOOL="none"
-inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
+# Bootstrapping Python 3 requires any Python version.
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
MY_P="Python-${PV}"
PATCHSET_REVISION="1"
@@ -40,6 +43,7 @@ RDEPEND="app-arch/bzip2
xml? ( >=dev-libs/expat-2.1 )
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"