summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/ChangeLog5
-rw-r--r--dev-lang/rust-bin/rust-bin-1.0.0.ebuild11
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-lang/rust-bin/ChangeLog b/dev-lang/rust-bin/ChangeLog
index bbb4175d12d5..3092615a433d 100644
--- a/dev-lang/rust-bin/ChangeLog
+++ b/dev-lang/rust-bin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/rust-bin
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/ChangeLog,v 1.8 2015/06/04 11:41:51 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/ChangeLog,v 1.9 2015/06/06 15:42:44 jauhien Exp $
+
+ 06 Jun 2015; Jauhien Piatlicki <jauhien@gentoo.org> rust-bin-1.0.0.ebuild:
+ move to new SLOTs schema
*rust-bin-1.0.0 (04 Jun 2015)
diff --git a/dev-lang/rust-bin/rust-bin-1.0.0.ebuild b/dev-lang/rust-bin/rust-bin-1.0.0.ebuild
index 41282d55a9ec..dd18cab89684 100644
--- a/dev-lang/rust-bin/rust-bin-1.0.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.0.0.ebuild
@@ -1,23 +1,20 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-1.0.0.ebuild,v 1.1 2015/06/04 11:41:51 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-1.0.0.ebuild,v 1.2 2015/06/06 15:42:44 jauhien Exp $
EAPI=5
inherit eutils bash-completion-r1
-BETA_NUM="${PV##*beta}"
-MY_PV="${PV/_/-}"
-# beta => beta BUT beta2 => beta.2
-[ -n "${BETA_NUM}" ] && MY_PV="${MY_PV/beta/beta.}"
-MY_P="rustc-${MY_PV}"
+MY_P="rustc-${PV}"
+
DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="http://www.rust-lang.org/"
SRC_URI="amd64? ( http://static.rust-lang.org/dist/${MY_P}-x86_64-unknown-linux-gnu.tar.gz )
x86? ( http://static.rust-lang.org/dist/${MY_P}-i686-unknown-linux-gnu.tar.gz )"
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-SLOT="1.0"
+SLOT="stable"
KEYWORDS="~amd64 ~x86"
IUSE=""