summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/galib/galib-2.4.5.ebuild')
-rw-r--r--dev-libs/galib/galib-2.4.5.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-libs/galib/galib-2.4.5.ebuild b/dev-libs/galib/galib-2.4.5.ebuild
index 24c15f856a82..5ea5b3f43074 100644
--- a/dev-libs/galib/galib-2.4.5.ebuild
+++ b/dev-libs/galib/galib-2.4.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/galib/galib-2.4.5.ebuild,v 1.2 2003/11/21 07:07:42 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/galib/galib-2.4.5.ebuild,v 1.3 2004/05/27 13:36:52 phosphan Exp $
+
+inherit eutils
DESCRIPTION="library for using genetic algorithms in C++ programs"
@@ -14,6 +16,17 @@ DEPEND=">=sys-apps/sed-4"
S=${WORKDIR}/galib245
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc3.3.patch
+ for file in examples/*.C ga/gaconfig.h; do
+ for thing in iostream fstream; do
+ sed -e "s:${thing}.h:${thing}:" -i ${file};
+ done
+ done
+}
+
src_compile() {
make CXXFLAGS="${CXXFLAGS}" || die "make failed"
}