summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gmp/gmp-5.0.1.ebuild')
-rw-r--r--dev-libs/gmp/gmp-5.0.1.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-libs/gmp/gmp-5.0.1.ebuild b/dev-libs/gmp/gmp-5.0.1.ebuild
index 3894621e58f1..1ae1f58821b5 100644
--- a/dev-libs/gmp/gmp-5.0.1.ebuild
+++ b/dev-libs/gmp/gmp-5.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-5.0.1.ebuild,v 1.7 2010/11/11 17:33:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-5.0.1.ebuild,v 1.8 2010/11/16 21:01:19 jer Exp $
inherit flag-o-matic eutils libtool flag-o-matic toolchain-funcs
@@ -41,6 +41,12 @@ src_unpack() {
}
src_compile() {
+ # Because of our 32-bit userland, 1.0 is the only HPPA ABI that works
+ # http://gmplib.org/manual/ABI-and-ISA.html#ABI-and-ISA (bug #344613)
+ if [[ ${CHOST} == hppa2.0-* ]] ; then
+ export GMPABI="1.0"
+ fi
+
# ABI mappings (needs all architectures supported)
case ${ABI} in
32|x86) GMPABI=32;;
@@ -56,14 +62,6 @@ src_compile() {
$(use_enable !nocxx cxx) \
|| die "configure failed"
- # Fix the ABI for hppa2.0
- if [[ -n ${is_hppa_2_0} ]] ; then
- sed -i \
- -e 's:pa32/hppa1_1:pa32/hppa2_0:' \
- "${S}"/config.h || die
- export CHOST=${CHOST/1.1/2.0}
- fi
-
emake || die "emake failed"
}