summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgpg-error/libgpg-error-1.4.ebuild')
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libgpg-error/libgpg-error-1.4.ebuild b/dev-libs/libgpg-error/libgpg-error-1.4.ebuild
new file mode 100644
index 000000000000..5a93475ec268
--- /dev/null
+++ b/dev-libs/libgpg-error/libgpg-error-1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/libgpg-error-1.4.ebuild,v 1.1 2006/10/29 20:04:41 alonbl Exp $
+
+inherit libtool eutils
+
+DESCRIPTION="Contains error handling functions used by GnuPG software"
+HOMEPAGE="http://www.gnupg.org/(en)/download/index.html#libgpg-error"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+}