summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libyaml/libyaml-0.0.1.ebuild')
-rw-r--r--dev-libs/libyaml/libyaml-0.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/libyaml/libyaml-0.0.1.ebuild b/dev-libs/libyaml/libyaml-0.0.1.ebuild
new file mode 100644
index 000000000000..6c38c983bc4c
--- /dev/null
+++ b/dev-libs/libyaml/libyaml-0.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/libyaml-0.0.1.ebuild,v 1.1 2007/10/05 22:49:01 sbriesen Exp $
+
+inherit eutils
+
+MY_P="${P/lib}"
+
+DESCRIPTION="YAML 1.1 parser and emitter written in C"
+HOMEPAGE="http://pyyaml.org/wiki/LibYAML"
+SRC_URI="http://pyyaml.org/download/libyaml/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="doc"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ use doc && dohtml -r doc/html/.
+ dodoc LICENSE README
+}