summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-lml')
-rw-r--r--dev-lisp/cl-lml/ChangeLog8
-rw-r--r--dev-lisp/cl-lml/Manifest6
-rw-r--r--dev-lisp/cl-lml/cl-lml-2.5.2.ebuild36
-rw-r--r--dev-lisp/cl-lml/files/digest-cl-lml-2.5.21
-rw-r--r--dev-lisp/cl-lml/metadata.xml5
5 files changed, 54 insertions, 2 deletions
diff --git a/dev-lisp/cl-lml/ChangeLog b/dev-lisp/cl-lml/ChangeLog
index 831fc2d810d7..06bcd5135670 100644
--- a/dev-lisp/cl-lml/ChangeLog
+++ b/dev-lisp/cl-lml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/cl-lml
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lml/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lml/ChangeLog,v 1.2 2003/10/17 17:17:02 mkennedy Exp $
+
+*cl-lml-2.5.2 (16 Oct 2003)
+
+ 16 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> cl-lml-2.5.2.ebuild,
+ metadata.xml:
+ new upstream, doc fixes, examples, preinst, postrm
*cl-lml-2.3.4 (07 Jul 2003)
diff --git a/dev-lisp/cl-lml/Manifest b/dev-lisp/cl-lml/Manifest
index 31d4ca7ac8c3..a19be18af35a 100644
--- a/dev-lisp/cl-lml/Manifest
+++ b/dev-lisp/cl-lml/Manifest
@@ -1,3 +1,7 @@
-MD5 494f26c970fffcb80bc516ffa5861622 ChangeLog 315
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
MD5 fd7ed4a4fedb146f3fb7afd24726c4e2 cl-lml-2.3.4.ebuild 684
+MD5 33a36e99f9008a866cf11e1809b44f17 cl-lml-2.5.2.ebuild 825
+MD5 fd7ed4a4fedb146f3fb7afd24726c4e2 cl-lml-2.5.2.ebuild~ 684
+MD5 494f26c970fffcb80bc516ffa5861622 ChangeLog 315
+MD5 291472bb2e3a8f9c86eaf5afa390252a files/digest-cl-lml-2.5.2 60
MD5 6bb77e58feb4637639cc0c8df37a4ade files/digest-cl-lml-2.3.4 60
diff --git a/dev-lisp/cl-lml/cl-lml-2.5.2.ebuild b/dev-lisp/cl-lml/cl-lml-2.5.2.ebuild
new file mode 100644
index 000000000000..321a63ca7f56
--- /dev/null
+++ b/dev-lisp/cl-lml/cl-lml-2.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lml/cl-lml-2.5.2.ebuild,v 1.1 2003/10/17 17:17:02 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package to provide a markup language for generation XHTML web pages"
+HOMEPAGE="http://lml.b9.com/
+ http://www.cliki.net/LML"
+SRC_URI="ftp://lml.med-info.com/lml-${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=lml
+
+S=${WORKDIR}/lml-${PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dohtml doc/readme.html
+ docinto examples
+ dodoc doc/readme.lml
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-lml/files/digest-cl-lml-2.5.2 b/dev-lisp/cl-lml/files/digest-cl-lml-2.5.2
new file mode 100644
index 000000000000..42b09f6d839e
--- /dev/null
+++ b/dev-lisp/cl-lml/files/digest-cl-lml-2.5.2
@@ -0,0 +1 @@
+MD5 3ab501a278df5e2d80881b5c17c4f7af lml-2.5.2.tar.gz 13073
diff --git a/dev-lisp/cl-lml/metadata.xml b/dev-lisp/cl-lml/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-lml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>