summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlp5/camlp5-5.05.ebuild')
-rw-r--r--dev-ml/camlp5/camlp5-5.05.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/camlp5/camlp5-5.05.ebuild b/dev-ml/camlp5/camlp5-5.05.ebuild
new file mode 100644
index 000000000000..58e0bb49de63
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.05.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.05.ebuild,v 1.1 2007/12/17 17:41:15 aballier Exp $
+
+inherit multilib findlib
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.09"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+
+ emake -j1 world.opt || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}