summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5/onphp/onphp-0.2.2.ebuild')
-rw-r--r--dev-php5/onphp/onphp-0.2.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php5/onphp/onphp-0.2.2.ebuild b/dev-php5/onphp/onphp-0.2.2.ebuild
new file mode 100644
index 000000000000..76d935842d95
--- /dev/null
+++ b/dev-php5/onphp/onphp-0.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.2.2.ebuild,v 1.1 2005/11/11 01:09:58 voxus Exp $
+
+DESCRIPTION="onPHP is the GPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.shadanakar.org/"
+SRC_URI="http://onphp.shadanakar.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=virtual/php-5.0.0"
+
+TARGETDIR="${D}/usr/share/php/${PN}"
+
+src_install() {
+ use doc && {
+ find doc -maxdepth 1 -type f -exec dodoc {} \;
+ }
+
+ mkdir -p ${TARGETDIR}
+
+ cp -pPR core main ${TARGETDIR}/
+ cp global.inc.php.tpl ${TARGETDIR}/global.inc.php
+}