summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/logilab-common/logilab-common-0.59.0.ebuild')
-rw-r--r--dev-python/logilab-common/logilab-common-0.59.0.ebuild27
1 files changed, 4 insertions, 23 deletions
diff --git a/dev-python/logilab-common/logilab-common-0.59.0.ebuild b/dev-python/logilab-common/logilab-common-0.59.0.ebuild
index 962f5fb14c45..78d55fe5093f 100644
--- a/dev-python/logilab-common/logilab-common-0.59.0.ebuild
+++ b/dev-python/logilab-common/logilab-common-0.59.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.0.ebuild,v 1.6 2013/02/10 05:27:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.0.ebuild,v 1.7 2013/02/10 11:55:24 mgorny Exp $
EAPI=5
# broken with python3.3, bug #449276
@@ -51,33 +51,14 @@ python_compile_all() {
}
python_test() {
- # The package has to be 'installed' before testing.
- # 1) because of namespaces, we can't use 'install --root',
- # 2) 'install --home' is terribly broken on pypy,
- # 3) non-root 'install' complains about PYTHONPATH and missing dirs,
- # so we need to set it properly and mkdir them,
- # 4) it runs a bunch of commands which write random files to cwd,
- # in order to avoid that, we need to run them ourselves to pass
- # alternate build paths,
- # 5) 'install' needs to go before 'bdist_egg' or the latter would
- # re-set install paths.
-
- local tpath=${BUILD_DIR}/test
- local bindir=${tpath}/bin
- local libdir=${tpath}/lib
- local PYTHONPATH=${libdir}:${PYTHONPATH}
-
- mkdir -p "${libdir}" || die
- esetup.py egg_info --egg-base="${tpath}" \
- install --install-lib="${libdir}" --install-scripts="${bindir}" \
- bdist_egg --dist-dir="${tpath}"
+ distutils_install_for_testing
# Prevent timezone related failure.
export TZ=UTC
# Make sure that the tests use correct modules.
- cd "${libdir}" || die
- "${bindir}"/pytest || die "Tests fail with ${EPYTHON}"
+ cd "${TEST_DIR}"/lib || die
+ "${TEST_DIR}"/scripts/pytest || die "Tests fail with ${EPYTHON}"
}
python_install_all() {