summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/manuel/manuel-1.7.1.ebuild')
-rw-r--r--dev-python/manuel/manuel-1.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/manuel/manuel-1.7.1.ebuild b/dev-python/manuel/manuel-1.7.1.ebuild
new file mode 100644
index 000000000000..bd30064af75b
--- /dev/null
+++ b/dev-python/manuel/manuel-1.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/manuel/manuel-1.7.1.ebuild,v 1.1 2013/03/15 19:19:27 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} python{3_1,3_2} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manuel lets you build tested documentation."
+HOMEPAGE="https://github.com/benji-york/manuel/ http://pypi.python.org/pypi/manuel"
+# A snapshot was required since upstream missed out half the source
+SRC_URI="http://dev.gentoo.org/~idella4/tarballs/${P}-20130316.tar.bz2"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES.txt )
+
+src_prepare() {
+ # Extract all refs to and use of zope.testing
+ epatch "${FILESDIR}"/${PN}-1.7-rm_zope_test.patch
+}
+
+python_test() {
+ PYTHONPATH=${BUILD_DIR}/lib esetup.py test
+}