summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyogg/pyogg-1.3-r1.ebuild')
-rw-r--r--dev-python/pyogg/pyogg-1.3-r1.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/pyogg/pyogg-1.3-r1.ebuild b/dev-python/pyogg/pyogg-1.3-r1.ebuild
index 31a084f91dc6..e9d2431e0f92 100644
--- a/dev-python/pyogg/pyogg-1.3-r1.ebuild
+++ b/dev-python/pyogg/pyogg-1.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyogg/pyogg-1.3-r1.ebuild,v 1.9 2005/10/02 14:16:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyogg/pyogg-1.3-r1.ebuild,v 1.10 2006/03/03 13:38:50 sbriesen Exp $
inherit distutils
@@ -10,18 +10,25 @@ HOMEPAGE="http://www.andrewchatham.com/pyogg/"
#SRC_URI="http://www.andrewchatham.com/pyogg/download/${P}.tar.gz"
SRC_URI="http://dev.gentoo.org/~kloeri/${P}-r1.tar.gz"
-IUSE=""
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="examples"
DEPEND="dev-lang/python
>=media-libs/libogg-1.0"
+DOCS="AUTHORS COPYING ChangeLog NEWS README"
+
src_compile() {
./config_unix.py || die
distutils_src_compile
}
-DOCS="AUTHORS COPYING ChangeLog NEWS README"
-
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*
+ fi
+}