summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyparted/pyparted-1.8.9.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-1.8.9.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-python/pyparted/pyparted-1.8.9.ebuild b/dev-python/pyparted/pyparted-1.8.9.ebuild
index 40ac975d938a..e6348b8d734f 100644
--- a/dev-python/pyparted/pyparted-1.8.9.ebuild
+++ b/dev-python/pyparted/pyparted-1.8.9.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.8.9.ebuild,v 1.2 2007/08/27 19:59:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.8.9.ebuild,v 1.3 2007/09/20 20:09:47 wolf31o2 Exp $
-inherit flag-o-matic
+inherit multilib
DESCRIPTION="Python bindings for parted"
HOMEPAGE="http://dcantrel.fedorapeople.org/pyparted/"
SRC_URI="http://dcantrel.fedorapeople.org/pyparted/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-DEPEND="sys-libs/ncurses"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-# Needed to build...
-DEPEND=">=dev-lang/python-2.4
- >=sys-apps/parted-1.7.0
- >=app-arch/rpm-4"
+DEPEND="sys-libs/ncurses
+ >=dev-lang/python-2.4
+ >=sys-apps/parted-1.7.0"
src_compile() {
- useq debug && append-flags -O -ggdb -DDEBUG
+ sed -i "s/\$(shell rpm --eval \"%{_libdir}\")/usr\/$(get_libdir)/" Makefile || die "cannot fix libdir"
emake || die "make failed"
}