summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog10
-rw-r--r--dev-python/pytest/pytest-2.3.5.ebuild48
-rw-r--r--dev-python/pytest/pytest-2.4.2.ebuild60
-rw-r--r--dev-python/pytest/pytest-2.5.2.ebuild56
-rw-r--r--dev-python/pytest/pytest-2.7.0-r1.ebuild (renamed from dev-python/pytest/pytest-2.7.0.ebuild)18
5 files changed, 20 insertions, 172 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index ec538aa3251f..6b3a56bf5822 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.114 2015/04/05 04:36:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.115 2015/04/05 13:07:43 idella4 Exp $
+
+*pytest-2.7.0-r1 (05 Apr 2015)
+
+ 05 Apr 2015; Ian Delaney <idella4@gentoo.org> +pytest-2.7.0-r1.ebuild,
+ -pytest-2.3.5.ebuild, -pytest-2.4.2.ebuild, -pytest-2.5.2.ebuild,
+ -pytest-2.7.0.ebuild:
+ revbump; drop un-needed dep, update test phase to match its current state, rm
+ 2.7.0 and old
*pytest-2.7.0 (05 Apr 2015)
diff --git a/dev-python/pytest/pytest-2.3.5.ebuild b/dev-python/pytest/pytest-2.3.5.ebuild
deleted file mode 100644
index afbf0a33d997..000000000000
--- a/dev-python/pytest/pytest-2.3.5.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.5.ebuild,v 1.18 2014/03/31 20:31:59 mgorny Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-inherit distutils-r1 eutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.13"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Disable versioning of py.test script to avoid collision with
- # versioning performed by the eclass.
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- mkdir doc/en/.build || die
- emake -C doc/en html
- fi
-}
-
-python_test() {
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && dohtml -r doc/en/_build/html/
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pytest/pytest-2.4.2.ebuild b/dev-python/pytest/pytest-2.4.2.ebuild
deleted file mode 100644
index b0e3d2e2ab54..000000000000
--- a/dev-python/pytest/pytest-2.4.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.18 2014/11/10 11:21:56 ago Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-inherit distutils-r1 eutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.17"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-
-#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 'python*')
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/pytest-2.4.2-pexpect-3.0.patch"
-)
-
-python_prepare_all() {
- # Disable versioning of py.test script to avoid collision with
- # versioning performed by the eclass.
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- mkdir doc/en/.build || die
- emake -C doc/en html
- fi
-}
-
-python_test() {
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
- --ignore=doc/en/example/nonpython/test_simple.yml \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && dohtml -r doc/en/_build/html/
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pytest/pytest-2.5.2.ebuild b/dev-python/pytest/pytest-2.5.2.ebuild
deleted file mode 100644
index b731bf76c695..000000000000
--- a/dev-python/pytest/pytest-2.5.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.6 2014/07/19 18:59:11 floppym Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
-inherit distutils-r1 eutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.20"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-
-#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 'python*')
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Disable versioning of py.test script to avoid collision with
- # versioning performed by the eclass.
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- mkdir doc/en/.build || die
- emake -C doc/en html
- fi
-}
-
-python_test() {
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
- --ignore=doc/en/example/nonpython/test_simple.yml \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && dohtml -r doc/en/_build/html/
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pytest/pytest-2.7.0.ebuild b/dev-python/pytest/pytest-2.7.0-r1.ebuild
index f1fb5e57fa55..42db8e5991ad 100644
--- a/dev-python/pytest/pytest-2.7.0.ebuild
+++ b/dev-python/pytest/pytest-2.7.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.7.0.ebuild,v 1.1 2015/04/05 04:36:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.7.0-r1.ebuild,v 1.1 2015/04/05 13:07:43 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
@@ -22,9 +22,7 @@ RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}] )
+ test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
python_prepare_all() {
@@ -46,9 +44,15 @@ python_compile_all() {
}
python_test() {
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
- --ignore=doc/en/example/nonpython/test_simple.yml \
- || die "tests failed with ${EPYTHON}"
+ # test_nose.py not written to suit py3.2 in pypy3
+ if [[ "${EPYTHON}" == pypy3 ]]; then
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
+ --ignore=testing/test_nose.py \
+ || die "tests failed with ${EPYTHON}"
+ else
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
+ || die "tests failed with ${EPYTHON}"
+ fi
}
python_install_all() {