summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip/sip-3.10.2.ebuild')
-rw-r--r--dev-python/sip/sip-3.10.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sip/sip-3.10.2.ebuild b/dev-python/sip/sip-3.10.2.ebuild
new file mode 100644
index 000000000000..0c3c9989ec2d
--- /dev/null
+++ b/dev-python/sip/sip-3.10.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.10.2.ebuild,v 1.1 2004/05/22 19:54:14 carlo Exp $
+
+IUSE=""
+
+inherit distutils
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc
+ x11-libs/qt
+ virtual/python"
+
+src_compile(){
+ distutils_python_version
+ python configure.py -l qt-mt \
+ -b /usr/bin \
+ -d /usr/lib/python${PYVER}/site-packages \
+ -e /usr/include/python${PYVER} \
+ "CXXFLAGS+=${CXXFLAGS}"
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die
+ dodoc ChangeLog LICENSE NEWS README THANKS TODO
+}