summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cvxopt/ChangeLog9
-rw-r--r--dev-python/cvxopt/cvxopt-1.1.4-r1.ebuild (renamed from dev-python/cvxopt/cvxopt-1.1.4.ebuild)5
-rw-r--r--dev-python/cvxopt/files/cvxopt-setup.patch55
3 files changed, 39 insertions, 30 deletions
diff --git a/dev-python/cvxopt/ChangeLog b/dev-python/cvxopt/ChangeLog
index 1953045043bd..051a4fc571d0 100644
--- a/dev-python/cvxopt/ChangeLog
+++ b/dev-python/cvxopt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/cvxopt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/ChangeLog,v 1.2 2012/01/16 20:35:26 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/ChangeLog,v 1.3 2012/01/17 18:28:45 bicatali Exp $
+
+*cvxopt-1.1.4-r1 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> -cvxopt-1.1.4.ebuild,
+ +cvxopt-1.1.4-r1.ebuild, files/cvxopt-setup.patch:
+ Fixed missing components (bug #399029, thanks Francois Bissey), removed
+ useless seds and fixed optional sed's
16 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> cvxopt-1.1.4.ebuild:
Fixed doc generation, bug #398857 thanks Martin von Gagern
diff --git a/dev-python/cvxopt/cvxopt-1.1.4.ebuild b/dev-python/cvxopt/cvxopt-1.1.4-r1.ebuild
index 55cf23220331..021019810d22 100644
--- a/dev-python/cvxopt/cvxopt-1.1.4.ebuild
+++ b/dev-python/cvxopt/cvxopt-1.1.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/cvxopt-1.1.4.ebuild,v 1.2 2012/01/16 20:35:26 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/cvxopt-1.1.4-r1.ebuild,v 1.1 2012/01/17 18:28:45 bicatali Exp $
EAPI=4
@@ -49,13 +49,12 @@ src_prepare(){
use_cvx() {
if use ${1}; then
sed -i \
- -e "s/\(BUILD_${2^^} =\) 0/\1 1/" \
+ -e "s/\(BUILD_${1^^} =\) 0/\1 1/" \
setup.py || die
fi
}
pkg_lib blas
- pkg_lib cblas
pkg_lib lapack
use_cvx gsl && pkg_lib gsl
use_cvx fftw && pkg_lib fftw3
diff --git a/dev-python/cvxopt/files/cvxopt-setup.patch b/dev-python/cvxopt/files/cvxopt-setup.patch
index a628cdae9a3a..fcef6e40bfa1 100644
--- a/dev-python/cvxopt/files/cvxopt-setup.patch
+++ b/dev-python/cvxopt/files/cvxopt-setup.patch
@@ -1,6 +1,6 @@
---- setup.py.orig 2012-01-06 04:59:53.000000000 +0000
-+++ setup.py 2012-01-06 06:21:48.000000000 +0000
-@@ -2,58 +2,58 @@
+--- setup.py.orig 2011-12-22 10:53:49.000000000 +1300
++++ setup.py 2012-01-16 11:17:04.207596266 +1300
+@@ -2,73 +2,57 @@
from glob import glob
# directory containing libblas and liblapack
@@ -13,33 +13,30 @@
# Directory containing libgsl (used only when BUILD_GSL = 1).
-GSL_LIB_DIR = '/usr/lib'
-+GSL_LIB_DIR = ''
-
- # Directory containing the GSL header files (used only when BUILD_GSL = 1).
+-
+-# Directory containing the GSL header files (used only when BUILD_GSL = 1).
-GSL_INC_DIR = '/usr/include/gsl'
-+GSL_INC_DIR = ''
++GSL_LIB_DIR = ''
# Set to 1 if you are installing the fftw module.
BUILD_FFTW = 0
# Directory containing libfftw3 (used only when BUILD_FFTW = 1).
-FFTW_LIB_DIR = '/usr/lib'
-+FFTW_LIB_DIR = ''
-
- # Directory containing fftw.h (used only when BUILD_FFTW = 1).
+-
+-# Directory containing fftw.h (used only when BUILD_FFTW = 1).
-FFTW_INC_DIR = '/usr/include'
-+FFTW_INC_DIR = ''
++FFTW_LIB_DIR = ''
# Set to 1 if you are installing the glpk module.
BUILD_GLPK = 0
# Directory containing libglpk (used only when BUILD_GLPK = 1).
-GLPK_LIB_DIR = '/usr/lib'
-+GLPK_LIB_DIR = ''
-
- # Directory containing glpk.h (used only when BUILD_GLPK = 1).
+-
+-# Directory containing glpk.h (used only when BUILD_GLPK = 1).
-GLPK_INC_DIR = '/usr/include'
-+GLPK_INC_DIR = ''
++GLPK_LIB_DIR = ''
# Set to 1 if you are installing the DSDP module.
BUILD_DSDP = 0
@@ -48,38 +45,44 @@
-DSDP_LIB_DIR = '/usr/lib'
+DSDP_LIB_DIR = ''
- # Directory containing dsdp5.h (used only when BUILD_DSDP = 1).
+-# Directory containing dsdp5.h (used only when BUILD_DSDP = 1).
-DSDP_INC_DIR = '/usr/include'
-+DSDP_INC_DIR = ''
-
+-
extmods = []
# optional modules
if BUILD_GSL:
- gsl = Extension('gsl', libraries = ['m', 'gsl', 'blas'],
+- include_dirs = [ GSL_INC_DIR ],
+ gsl = Extension('gsl', libraries = ['gsl'],
- include_dirs = [ GSL_INC_DIR ],
library_dirs = [ GSL_LIB_DIR ],
sources = ['C/gsl.c'] )
extmods += [gsl];
if BUILD_FFTW:
- fftw = Extension('fftw', libraries = ['fftw3', 'blas'],
+- include_dirs = [ FFTW_INC_DIR ],
+ fftw = Extension('fftw', libraries = ['fftw3'],
- include_dirs = [ FFTW_INC_DIR ],
library_dirs = [ FFTW_LIB_DIR, ATLAS_LIB_DIR ],
sources = ['C/fftw.c'] )
-@@ -67,7 +67,7 @@
+ extmods += [fftw];
+
+ if BUILD_GLPK:
+ glpk = Extension('glpk', libraries = ['glpk'],
+- include_dirs = [ GLPK_INC_DIR ],
+ library_dirs = [ GLPK_LIB_DIR ],
+ sources = ['C/glpk.c'] )
extmods += [glpk];
if BUILD_DSDP:
- dsdp = Extension('dsdp', libraries = ['dsdp', 'blas', 'lapack'],
+- include_dirs = [ DSDP_INC_DIR ],
+ dsdp = Extension('dsdp', libraries = ['dsdp'],
- include_dirs = [ DSDP_INC_DIR ],
library_dirs = [ DSDP_LIB_DIR, ATLAS_LIB_DIR ],
sources = ['C/dsdp.c'] )
-@@ -85,7 +85,7 @@
+ extmods += [dsdp];
+@@ -85,7 +69,7 @@
else:
MACROS = []
@@ -88,7 +91,7 @@
library_dirs = [ ATLAS_LIB_DIR ],
define_macros = MACROS,
sources = ['C/base.c','C/dense.c','C/sparse.c'])
-@@ -95,22 +95,16 @@
+@@ -95,22 +79,16 @@
define_macros = MACROS,
sources = ['C/blas.c'] )
@@ -114,7 +117,7 @@
# Build for int or long?
import sys
-@@ -118,28 +112,16 @@
+@@ -118,28 +96,16 @@
cholmod = Extension('cholmod',
library_dirs = [ ATLAS_LIB_DIR ],
@@ -122,7 +125,7 @@
- include_dirs = [ 'C/SuiteSparse/CHOLMOD/Include',
- 'C/SuiteSparse/COLAMD', 'C/SuiteSparse/AMD/Include',
- 'C/SuiteSparse/UFconfig', 'C/SuiteSparse/COLAMD/Include' ],
-+ libraries = ['cholmod' ],
++ libraries = ['cholmod','blas'],
define_macros = MACROS + [('NPARTITION', '1')],
- sources = [ 'C/cholmod.c' ] +
- ['C/SuiteSparse/AMD/Source/' + s for s in ['amd_global.c',