summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask/ChangeLog8
-rw-r--r--dev-python/flask/flask-0.9.ebuild55
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index dee5eecab39a..311f41cc3576 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.14 2012/04/10 13:02:32 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.15 2012/08/17 07:45:01 patrick Exp $
+
+*flask-0.9 (17 Aug 2012)
+
+ 17 Aug 2012; Patrick Lauer <patrick@gentoo.org> +flask-0.9.ebuild:
+ Bump for #425186
*flask-9999 (10 Apr 2012)
@@ -63,4 +68,3 @@
30 May 2010; Dirkjan Ochtman <djc@gentoo.org> +flask-0.3.1.ebuild,
+metadata.xml:
Initial version, contributed by plaes@plaes.org.
-
diff --git a/dev-python/flask/flask-0.9.ebuild b/dev-python/flask/flask-0.9.ebuild
new file mode 100644
index 000000000000..67bfaaaf27ca
--- /dev/null
+++ b/dev-python/flask/flask-0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.9.ebuild,v 1.1 2012/08/17 07:45:01 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="http://pypi.python.org/pypi/Flask"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+# USE doc removed because it acquires content from the network in building
+
+RDEPEND="dev-python/blinker
+ >=dev-python/jinja-2.4
+ dev-python/setuptools
+ >=dev-python/werkzeug-0.6.1"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Fixed an issue with an unused module for Python 2.5 (flask.session)
+ # https://github.com/mitsuhiko/flask/commit/0dd9dc37b6618b8091c2a0f849f5f3143dc6eafc
+ sed -e "s/\(from .sessions import\).*/\1 SecureCookieSession, NullSession/" -i flask/session.py || die
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}