summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog8
-rw-r--r--dev-ruby/activesupport/Manifest3
-rw-r--r--dev-ruby/activesupport/activesupport-1.1.1-r1.ebuild26
-rw-r--r--dev-ruby/activesupport/files/as_clean_logger_rb-fixed.patch13
-rw-r--r--dev-ruby/activesupport/files/digest-activesupport-1.1.1-r11
5 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 6db424f19259..ee06ae8da000 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.12 2005/09/23 01:34:25 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.13 2005/09/26 15:59:20 caleb Exp $
+
+*activesupport-1.1.1-r1 (26 Sep 2005)
+
+ 26 Sep 2005; Caleb Tennis <caleb@gentoo.org>
+ +files/as_clean_logger_rb-fixed.patch, +activesupport-1.1.1-r1.ebuild:
+ Fix broken rails from 1.8.3 Ruby upgrade - Bug #107099
23 Sep 2005; Caleb Tennis <caleb@gentoo.org> -activesupport-1.0.0.ebuild,
-activesupport-1.0.1.ebuild, -activesupport-1.0.2.ebuild,
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 2764ea1a9628..61f93e9add5e 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,4 +1,7 @@
MD5 9c01907ba62cf747089ec158a3aa1e7d activesupport-1.1.1.ebuild 721
+MD5 832535413eb04a4b0721de792072fc93 activesupport-1.1.1-r1.ebuild 868
MD5 a9e4826d52b7df8a36ba5717778ac615 ChangeLog 1752
MD5 3eec9f3fe48b51f49dbc1f171a3b026f metadata.xml 157
MD5 3cc7197f8083599bef3678502c6b11a8 files/digest-activesupport-1.1.1 67
+MD5 98c856c2201ed8c0cc866e76dafd967f files/as_clean_logger_rb-fixed.patch 461
+MD5 3cc7197f8083599bef3678502c6b11a8 files/digest-activesupport-1.1.1-r1 67
diff --git a/dev-ruby/activesupport/activesupport-1.1.1-r1.ebuild b/dev-ruby/activesupport/activesupport-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..63cc6b31ee0a
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-1.1.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-1.1.1-r1.ebuild,v 1.1 2005/09/26 15:59:20 caleb Exp $
+
+inherit ruby gems eutils
+
+USE_RUBY="ruby18"
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+# The URL depends implicitly on the version, unfortunately. Even if you
+# change the filename on the end, it still downloads the same file.
+SRC_URI="http://rubyforge.org/frs/download.php/5160/${P}.gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.2
+ >=dev-ruby/rubygems-0.8.10"
+
+src_install() {
+ gems_src_install
+ cd ${D}/${GEMSDIR}/gems
+ patch -p0 < ${FILESDIR}/as_clean_logger_rb-fixed.patch
+}
diff --git a/dev-ruby/activesupport/files/as_clean_logger_rb-fixed.patch b/dev-ruby/activesupport/files/as_clean_logger_rb-fixed.patch
new file mode 100644
index 000000000000..b98f411fd5a1
--- /dev/null
+++ b/dev-ruby/activesupport/files/as_clean_logger_rb-fixed.patch
@@ -0,0 +1,13 @@
+--- activesupport-1.1.1/lib/active_support/clean_logger.rb.orig 2005-09-21 00:31:08.000000000 -0700
++++ activesupport-1.1.1/lib/active_support/clean_logger.rb 2005-09-21 00:45:36.000000000 -0700
+@@ -10,7 +10,9 @@
+ end
+
+ private
+- remove_const "Format"
++ if const_defined?(:Format) # Not defined in Ruby 1.8.3
++ remove_const "Format"
++ end
+ Format = "%s\n"
+ def format_message(severity, timestamp, msg, progname)
+ Format % [msg]
diff --git a/dev-ruby/activesupport/files/digest-activesupport-1.1.1-r1 b/dev-ruby/activesupport/files/digest-activesupport-1.1.1-r1
new file mode 100644
index 000000000000..bb6a24882e63
--- /dev/null
+++ b/dev-ruby/activesupport/files/digest-activesupport-1.1.1-r1
@@ -0,0 +1 @@
+MD5 091d2d98f3bf2bda1de0ad9f4368b28e activesupport-1.1.1.gem 26624