summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mocha/mocha-0.9.8-r1.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-0.9.8-r1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-ruby/mocha/mocha-0.9.8-r1.ebuild b/dev-ruby/mocha/mocha-0.9.8-r1.ebuild
deleted file mode 100644
index 3d58a0dc8132..000000000000
--- a/dev-ruby/mocha/mocha-0.9.8-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/mocha-0.9.8-r1.ebuild,v 1.2 2009/12/30 13:26:43 armin76 Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README RELEASE"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby library for mocking and stubbing using a syntax like that of JMock, and SchMock"
-HOMEPAGE="http://mocha.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
-IUSE=""
-
-ruby_add_bdepend test virtual/ruby-test-unit
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- rake examples || die
- fi
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*.rb || die
-}