summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/treetop/treetop-1.4.3.ebuild')
-rw-r--r--dev-ruby/treetop/treetop-1.4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/treetop/treetop-1.4.3.ebuild b/dev-ruby/treetop/treetop-1.4.3.ebuild
new file mode 100644
index 000000000000..891ab39b736b
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/treetop-1.4.3.ebuild,v 1.1 2009/12/16 18:49:51 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages."
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc examples"
+
+ruby_add_rdepend ">=dev-ruby/polyglot-0.2.5"
+
+all_ruby_install() {
+ dodoc README.md
+
+ use doc && dodoc -r doc/*
+
+ if use examples; then
+ cp -pPR examples "${D}/usr/share/doc/${PF}" || die "Failed installing example files."
+ fi
+}