summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/unf/unf-0.0.5.ebuild')
-rw-r--r--dev-ruby/unf/unf-0.0.5.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-ruby/unf/unf-0.0.5.ebuild b/dev-ruby/unf/unf-0.0.5.ebuild
index f6b87a8b8526..01e5f5c04dce 100644
--- a/dev-ruby/unf/unf-0.0.5.ebuild
+++ b/dev-ruby/unf/unf-0.0.5.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/unf-0.0.5.ebuild,v 1.1 2012/05/13 06:35:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/unf-0.0.5.ebuild,v 1.2 2012/08/14 16:58:13 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18 jruby"
+RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -20,16 +21,18 @@ KEYWORDS="~amd64"
IUSE="test"
# jruby already has support for UNF so it does not need the extension.
-USE_RUBY=ruby18 ruby_add_rdepend "dev-ruby/unf_ext"
-USE_RUBY=ruby19 ruby_add_rdepend "dev-ruby/unf_ext"
-USE_RUBY=ree18 ruby_add_rdepend "dev-ruby/unf_ext"
+USE_RUBY=${USE_RUBY/jruby/} ruby_add_rdepend "dev-ruby/unf_ext"
-ruby_add_bdepend "test? ( dev-ruby/shoulda )"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
all_ruby_prepare() {
sed -i -e '/bundler/,/end/ s:^:#:' test/helper.rb || die
}
each_ruby_test() {
- ${RUBY} -S testrb test/test_*.rb || die
+ ruby-ng_testrb-2 test/test_*.rb
}