summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/bigloo')
-rw-r--r--dev-scheme/bigloo/ChangeLog8
-rw-r--r--dev-scheme/bigloo/bigloo-2.9a.ebuild78
-rw-r--r--dev-scheme/bigloo/files/50bigloo-gentoo.el2
-rw-r--r--dev-scheme/bigloo/files/digest-bigloo-2.9a3
4 files changed, 89 insertions, 2 deletions
diff --git a/dev-scheme/bigloo/ChangeLog b/dev-scheme/bigloo/ChangeLog
index ba4100a5026b..5ece110c09f6 100644
--- a/dev-scheme/bigloo/ChangeLog
+++ b/dev-scheme/bigloo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-scheme/bigloo
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.9 2007/01/15 11:28:53 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.10 2007/02/15 14:28:44 hkbst Exp $
+
+*bigloo-2.9a (15 Feb 2007)
+
+ 15 Feb 2007; Marijn Schouten <hkBst@gentoo.org> files/50bigloo-gentoo.el,
+ +bigloo-2.9a.ebuild:
+ add 2.9a ebuild, bug 135447
15 Jan 2007; Steve Dibb <beandog@gentoo.org> bigloo-2.7a_p2.ebuild:
amd64 stable, bug 152062
diff --git a/dev-scheme/bigloo/bigloo-2.9a.ebuild b/dev-scheme/bigloo/bigloo-2.9a.ebuild
new file mode 100644
index 000000000000..e70e04f4f096
--- /dev/null
+++ b/dev-scheme/bigloo/bigloo-2.9a.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-2.9a.ebuild,v 1.1 2007/02/15 14:28:44 hkbst Exp $
+
+inherit elisp-common
+
+MY_P=${PN}${PV/_p/-r}
+
+DESCRIPTION="Bigloo is a Scheme implementation."
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="emacs? ( virtual/emacs )"
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE="50bigloo-gentoo.el"
+
+IUSE="emacs"
+# fullbee"
+
+src_compile() {
+ use emacs && elisp-comp etc/*.el
+
+ # Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --libdir=/usr/lib \
+ --docdir=/usr/share/doc/${PF} \
+ --benchmark=yes \
+ --sharedbde=no \
+ --sharedcompiler=no \
+ --coflags="" || die "configure failed"
+
+# --bee=$(if use fullbee; then echo full; else echo partial; fi) \
+
+ # parallel build is broken
+ emake -j1 || die "emake failed"
+}
+
+# make test does something weird so default src_test() in /usr/lib/portage/bin/ebuild.sh fails the following test
+# elif emake -j1 test -n &> /dev/null; then
+# so copy straight from default src_test() all the stuff which depends on that test passing
+src_test() {
+ vecho ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ if ! emake -j1 test; then
+ hasq test $FEATURES && die "Make test failed. See above for details."
+ hasq test $FEATURES || eerror "Make test failed. See above for details."
+ fi
+}
+
+src_install () {
+# dodir /etc/env.d
+# echo "LDPATH=/usr/lib/bigloo/${PV}/" > ${D}/etc/env.d/25bigloo
+
+ # make the links created not point to DESTDIR, since that is only a temporary home
+ sed 's/ln -s $(DESTDIR)/ln -s /' -i Makefile.misc
+ emake DESTDIR=${D} install || die "install failed"
+
+ if use emacs; then
+ elisp-install ${PN} etc/*.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+# einfo "Compiling bee..."
+# emake compile-bee || die "compiling bee failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-scheme/bigloo/files/50bigloo-gentoo.el b/dev-scheme/bigloo/files/50bigloo-gentoo.el
index c08f8aab8b2f..576bdde482e3 100644
--- a/dev-scheme/bigloo/files/50bigloo-gentoo.el
+++ b/dev-scheme/bigloo/files/50bigloo-gentoo.el
@@ -1,3 +1,3 @@
-;; site-lisp configuration for bigloo
+;;; dev-scheme/bigloo
(add-to-list 'load-path "@SITELISP@")
diff --git a/dev-scheme/bigloo/files/digest-bigloo-2.9a b/dev-scheme/bigloo/files/digest-bigloo-2.9a
new file mode 100644
index 000000000000..1a2bc4d4a82e
--- /dev/null
+++ b/dev-scheme/bigloo/files/digest-bigloo-2.9a
@@ -0,0 +1,3 @@
+MD5 10d04d4a7b883a6873d74da4ce62f0a2 bigloo2.9a.tar.gz 10270051
+RMD160 e2ac3836ecdc1277e1c43ce2a7d489e8d6112d38 bigloo2.9a.tar.gz 10270051
+SHA256 bce1b3f947ba518620afde075036032a9af084174fa4df561ec97952bc80110a bigloo2.9a.tar.gz 10270051