summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/expect/expect-5.37.1.ebuild')
-rw-r--r--dev-tcltk/expect/expect-5.37.1.ebuild30
1 files changed, 11 insertions, 19 deletions
diff --git a/dev-tcltk/expect/expect-5.37.1.ebuild b/dev-tcltk/expect/expect-5.37.1.ebuild
index cf60fd995b99..b379bf5a0dc3 100644
--- a/dev-tcltk/expect/expect-5.37.1.ebuild
+++ b/dev-tcltk/expect/expect-5.37.1.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1.ebuild,v 1.7 2003/02/13 11:45:45 vapier Exp $
-
-IUSE="X"
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1.ebuild,v 1.8 2003/04/23 16:01:36 vapier Exp $
#remove the trailing ".0" from the tarball version
S=${WORKDIR}/${P%.1}
-DESCRIPTION="Expect is a tool for automating interactive applications"
+DESCRIPTION="tool for automating interactive applications"
SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
HOMEPAGE="http://expect.nist.gov/"
SLOT="0"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
LICENSE="BSD"
+IUSE="X"
DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-
+ X? ( >=dev-lang/tk-8.2 )"
src_compile() {
-
local myconf
local tclv
local tkv
+
# Find the version of tcl/tk that has headers installed.
# This will be the most recently merged, not necessarily the highest
# version number.
@@ -34,27 +32,21 @@ src_compile() {
#configure needs to find the files tclConfig.sh and tclInt.h
myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
- if use X; then
+ if [ `use X` ]; then
#--with-x is enabled by default
#configure needs to find the file tkConfig.sh and tk.h
#tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/lib"
+ myconf="${myconf} --with-tk=/usr/lib"
else
#configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
+ myconf="${myconf} --without-x"
fi
- econf $myconf || die
+ econf ${myconf} || die
emake || die
-
}
-src_install () {
-
+src_install() {
einstall || die
-
- #docs
dodoc Changelog FAQ HISTORY NEWS README
-
}
-